use strict;
my $str = 'To: bill.rhodes@autozone.com
from: William rhodes
from: william.rhodes
From:willIAM.T.Rhodes
FROM: William C. Rhodes
from: WIlam Rhodes <william.rhodes@company.com)
from: Rhodes, WIlliam
from: rhodes.william@company.com
from: william.rhodes@company.com
From: "Rhodes, William" <william.rhodes@somecompany.com>
From: Rhodes, William <william.rhodes@somecompany.com>
From:
';
my $regex = qr/(?i)(?=.*\b^From:\s*\b)(?=.*\bwilliam\b)(?=.*\brhodes\b).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}