# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?=.*\b^From:\s*\b)(?=.*\bwilliam\b)(?=.*\brhodes\b).*"
test_str = ("To: bill.rhodes@autozone.com\n"
"from: William rhodes\n"
"from: william.rhodes\n"
"From:willIAM.T.Rhodes\n"
"FROM: William C. Rhodes\n"
"from: WIlam Rhodes <william.rhodes@company.com)\n"
"from: Rhodes, WIlliam\n"
"from: rhodes.william@company.com\n"
"from: william.rhodes@company.com\n\n"
"From: \"Rhodes, William\" <william.rhodes@somecompany.com>\n\n"
"From: Rhodes, William <william.rhodes@somecompany.com>\n"
"From: \n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.