import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?=.*\\b^From:\\s*\\b)(?=.*\\bwilliam\\b)(?=.*\\brhodes\\b).*";
final String string = "To: bill.rhodes@autozone.com\n"
+ "from: William rhodes\n"
+ "from: william.rhodes\n"
+ "From:willIAM.T.Rhodes\n"
+ "FROM: William C. Rhodes\n"
+ "from: WIlam Rhodes <william.rhodes@company.com)\n"
+ "from: Rhodes, WIlliam\n"
+ "from: rhodes.william@company.com\n"
+ "from: william.rhodes@company.com\n\n"
+ "From: \"Rhodes, William\" <william.rhodes@somecompany.com>\n\n"
+ "From: Rhodes, William <william.rhodes@somecompany.com>\n"
+ "From: \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}