#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^element(?:(?!^element)[\s\S])+"
Local $sString = "element : 1" & @CRLF & _
"" & @CRLF & _
"Description" & @CRLF & _
"This is the description of item 1" & @CRLF & _
"___________________" & @CRLF & _
"" & @CRLF & _
"element : 2" & @CRLF & _
"" & @CRLF & _
"Description" & @CRLF & _
"This is the description of item 2" & @CRLF & _
"______________________"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")