using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^element(?:(?!^element)[\s\S])+";
string input = @"element : 1
Description
This is the description of item 1
___________________
element : 2
Description
This is the description of item 2
______________________";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}