re = /^element(?:(?!^element)[\s\S])+/m
str = 'element : 1
Description
This is the description of item 1
___________________
element : 2
Description
This is the description of item 2
______________________'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end