const regex = /^element(?:(?!^element)[\s\S])+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^element(?:(?!^element)[\\s\\S])+', 'gm')
const str = `element : 1
Description
This is the description of item 1
___________________
element : 2
Description
This is the description of item 2
______________________`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}