#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.:\\folder\\.*?\\(*PRUNE)$"
Local $sString = "L:\folder\displace\" & @CRLF & _
"L:\folder\orthodox\limited\" & @CRLF & _
"L:\folder\guarantee\relation\" & @CRLF & _
"L:\folder\layout\"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")