const regex = /^.:\\folder\\.*?\\(*PRUNE)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.:\\\\folder\\\\.*?\\\\(*PRUNE)$', 'gm')
const str = `L:\\folder\\displace\\
L:\\folder\\orthodox\\limited\\
L:\\folder\\guarantee\\relation\\
L:\\folder\\layout\\`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}