$re = '/^.:\\\\folder\\\\.*?\\\\(*PRUNE)$/m';
$str = 'L:\\folder\\displace\\
L:\\folder\\orthodox\\limited\\
L:\\folder\\guarantee\\relation\\
L:\\folder\\layout\\';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);