package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.:\\folder\\.*?\\(*PRUNE)$`)
var str = `L:\folder\displace\
L:\folder\orthodox\limited\
L:\folder\guarantee\relation\
L:\folder\layout\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}