using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.:\\folder\\.*?\\(*PRUNE)$";
string input = @"L:\folder\displace\
L:\folder\orthodox\limited\
L:\folder\guarantee\relation\
L:\folder\layout\";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}