import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=[5KL]) # первый символ 5 или K или L\n"
+ "(?=..\\{,49\\}\\d) # должна быть хотя бы одна цифра\n"
+ "(?=..\\{,49\\}[a-z]) # должна быть хотя бы одна строчная буква\n"
+ "(?=..\\{,49\\}[A-Z]) # должна быть хотя бы одна заглавная буква\n"
+ "[a-zA-Z0-9]{51} # 51 цифра или буква, а условия указаны ранее";
final String string = "aaa5KXH6bXuyX7xDUiNDiyX2VqvePBqpAJWuKDypJBZeS9qPf3LNGJaaa // просто поиск\n"
+ "aaa5eeeeeeeEEEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // внутри нет цифр\n"
+ "// если 5 в начале подходит для условия наличия цифр, то не .{,49}, а {,50}\n"
+ "aaa5eeeeeeeeeeeeeeee1eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // нет заглавных\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}