use strict;
my $str = 'aaa5KXH6bXuyX7xDUiNDiyX2VqvePBqpAJWuKDypJBZeS9qPf3LNGJaaa // просто поиск
aaa5eeeeeeeEEEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // внутри нет цифр
// если 5 в начале подходит для условия наличия цифр, то не .{,49}, а {,50}
aaa5eeeeeeeeeeeeeeee1eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // нет заглавных
';
my $regex = qr/(?=[5KL]) # первый символ 5 или K или L
(?=..{,49}\d) # должна быть хотя бы одна цифра
(?=..{,49}[a-z]) # должна быть хотя бы одна строчная буква
(?=..{,49}[A-Z]) # должна быть хотя бы одна заглавная буква
[a-zA-Z0-9]{51} # 51 цифра или буква, а условия указаны ранее/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}