import Foundation
let pattern = ##"""
(?=[5KL]) # первый символ 5 или K или L
(?=..{,49}\d) # должна быть хотя бы одна цифра
(?=..{,49}[a-z]) # должна быть хотя бы одна строчная буква
(?=..{,49}[A-Z]) # должна быть хотя бы одна заглавная буква
[a-zA-Z0-9]{51} # 51 цифра или буква, а условия указаны ранее
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
aaa5KXH6bXuyX7xDUiNDiyX2VqvePBqpAJWuKDypJBZeS9qPf3LNGJaaa // просто поиск
aaa5eeeeeeeEEEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // внутри нет цифр
// если 5 в начале подходит для условия наличия цифр, то не .{,49}, а {,50}
aaa5eeeeeeeeeeeeeeee1eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // нет заглавных
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)