re = /(?=[5KL]) # первый символ 5 или K или L
(?=..{,49}\d) # должна быть хотя бы одна цифра
(?=..{,49}[a-z]) # должна быть хотя бы одна строчная буква
(?=..{,49}[A-Z]) # должна быть хотя бы одна заглавная буква
[a-zA-Z0-9]{51} # 51 цифра или буква, а условия указаны ранее/mx
str = 'aaa5KXH6bXuyX7xDUiNDiyX2VqvePBqpAJWuKDypJBZeS9qPf3LNGJaaa // просто поиск
aaa5eeeeeeeEEEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // внутри нет цифр
// если 5 в начале подходит для условия наличия цифр, то не .{,49}, а {,50}
aaa5eeeeeeeeeeeeeeee1eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeaaa // нет заглавных
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end