#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\bdr[.\s]\s?"
Local $sString = ""Dr. Drake Cohen" would become "Drake Cohen"" & @CRLF & _
""Dr Drake Cohen" would become "Drake Cohen"" & @CRLF & _
""Drake Cohen" would become "Drake Cohen"" & @CRLF & _
""Rachel Smith" would become "Rachel Smith"" & @CRLF & _
""Dr. Rachel Smith" would become "Rachel Smith"" & @CRLF & _
"alexandr the great"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")