import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bdr[.\\s]\\s?";
final String string = "\"Dr. Drake Cohen\" would become \"Drake Cohen\"\n"
+ "\"Dr Drake Cohen\" would become \"Drake Cohen\"\n"
+ "\"Drake Cohen\" would become \"Drake Cohen\"\n"
+ "\"Rachel Smith\" would become \"Rachel Smith\"\n"
+ "\"Dr. Rachel Smith\" would become \"Rachel Smith\"\n"
+ "alexandr the great";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}