import re
regex = re.compile(r"\bdr[.\s]\s?", flags=re.IGNORECASE)
test_str = ("\"Dr. Drake Cohen\" would become \"Drake Cohen\"\n"
"\"Dr Drake Cohen\" would become \"Drake Cohen\"\n"
"\"Drake Cohen\" would become \"Drake Cohen\"\n"
"\"Rachel Smith\" would become \"Rachel Smith\"\n"
"\"Dr. Rachel Smith\" would become \"Rachel Smith\"\n"
"alexandr the great")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")