using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bdr[.\s]\s?";
string input = @"""Dr. Drake Cohen"" would become ""Drake Cohen""
""Dr Drake Cohen"" would become ""Drake Cohen""
""Drake Cohen"" would become ""Drake Cohen""
""Rachel Smith"" would become ""Rachel Smith""
""Dr. Rachel Smith"" would become ""Rachel Smith""
alexandr the great";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}