re = /\bdr[.\s]\s?/i
str = '"Dr. Drake Cohen" would become "Drake Cohen"
"Dr Drake Cohen" would become "Drake Cohen"
"Drake Cohen" would become "Drake Cohen"
"Rachel Smith" would become "Rachel Smith"
"Dr. Rachel Smith" would become "Rachel Smith"
alexandr the great'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end