using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\d\d\d\) \d\d\d-\d\d\d\d";
string input = @"'Hello my number is (503) 232-7159 and I vote. Please call me.'";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}