$re = '/\(\d\d\d\) \d\d\d-\d\d\d\d/';
$str = '\'Hello my number is (503) 232-7159 and I vote. Please call me.\'';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);