re = /\(\d\d\d\) \d\d\d-\d\d\d\d/
str = '\'Hello my number is (503) 232-7159 and I vote. Please call me.\''
# Print the match result
str.match(re) do |match|
puts match.to_s
end