package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\d\d\d\) \d\d\d-\d\d\d\d`)
var str = `'Hello my number is (503) 232-7159 and I vote. Please call me.'`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}