const regex = new RegExp('\\(\\d\\d\\d\\) \\d\\d\\d-\\d\\d\\d\\d', '')
const str = `'Hello my number is (503) 232-7159 and I vote. Please call me.'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}