#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\/charts\/[a-z A-Z].*\/values\.yaml$"
Local $sString = "# Detect helm charts directory" & @CRLF & _
"" & @CRLF & _
"./frontend/charts/pentext-ui/values.yaml" & @CRLF & _
"./backend/charts/pentext-backend/values.yaml" & @CRLF & _
"./charts/pentext/values.yaml" & @CRLF & _
"./Dockerfile"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")