package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\/charts\/[a-z A-Z].*\/values\.yaml$`)
var str = `# Detect helm charts directory
./frontend/charts/pentext-ui/values.yaml
./backend/charts/pentext-backend/values.yaml
./charts/pentext/values.yaml
./Dockerfile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}