using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\/charts\/[a-z A-Z].*\/values\.yaml$";
string input = @"# Detect helm charts directory
./frontend/charts/pentext-ui/values.yaml
./backend/charts/pentext-backend/values.yaml
./charts/pentext/values.yaml
./Dockerfile";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}