re = /^.*\/charts\/[a-z A-Z].*\/values\.yaml$/m
str = '# Detect helm charts directory
./frontend/charts/pentext-ui/values.yaml
./backend/charts/pentext-backend/values.yaml
./charts/pentext/values.yaml
./Dockerfile'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end