$re = '/^.*\/charts\/[a-z A-Z].*\/values\.yaml$/m';
$str = '# Detect helm charts directory
./frontend/charts/pentext-ui/values.yaml
./backend/charts/pentext-backend/values.yaml
./charts/pentext/values.yaml
./Dockerfile';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);