# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\s*"Version"\s*:\s*")[^"]*/${1}10/gm;t' <<< "{
\"FramewokSettings\": {
\"Name\": \"VX\",
\"Version\": \"8\", // The value here is not constant. It can be something like v1.4.56.456 also
\"GitVersion\": \"v5\",
\"DatabaseVersion\": \"7\",
// Doing xyz
\"CounterVersion\": \"2\"
// Doing ABC.
// Start
}
}"