const regex = /^(\s*"Version"\s*:\s*")[^"]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*"Version"\\s*:\\s*")[^"]*', 'gm')
const str = `{
"FramewokSettings": {
"Name": "VX",
"Version": "8", // The value here is not constant. It can be something like v1.4.56.456 also
"GitVersion": "v5",
"DatabaseVersion": "7",
// Doing xyz
"CounterVersion": "2"
// Doing ABC.
// Start
}
}`;
const subst = `${1}10`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);