// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(\s*"Version"\s*:\s*")[^"]*"#).unwrap();
let string = "{
\"FramewokSettings\": {
\"Name\": \"VX\",
\"Version\": \"8\", // The value here is not constant. It can be something like v1.4.56.456 also
\"GitVersion\": \"v5\",
\"DatabaseVersion\": \"7\",
// Doing xyz
\"CounterVersion\": \"2\"
// Doing ABC.
// Start
}
}";
let substitution = "${1}10";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}