using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\s*""Version""\s*:\s*"")[^""]*";
string substitution = @"${1}10";
string input = @"{
""FramewokSettings"": {
""Name"": ""VX"",
""Version"": ""8"", // The value here is not constant. It can be something like v1.4.56.456 also
""GitVersion"": ""v5"",
""DatabaseVersion"": ""7"",
// Doing xyz
""CounterVersion"": ""2""
// Doing ABC.
// Start
}
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}