#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\+\d\s*\d(?:-?\d)+)([\w.-]+@[\w.-]+(?:\.[\w.-]+)*\.[a-z]{2,6})"
Local $sString = "Saturday, February 6, 2021 at 9:00 AM – 1:00 PM CST4 days from now · 9–21°C Partly CloudypinBraeswood Farmers Market5401 S Braeswood Blvd, 26096Show MapHide MapFarmers Market+1 913-620-5318info@bighome25.comGet DirectionsDetailsSouthwest Farmers Market located in the heart of City. Fresh farmed produce, pasture raised eggs, organically fed poultry, locally farmed honey, grass fed beef, fresh prepared gourmet foods, and delicious food trucks.Vendor Inquiries - info@bighome25.comFoodKid FriendlyFarmers market"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")