using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\+\d\s*\d(?:-?\d)+)([\w.-]+@[\w.-]+(?:\.[\w.-]+)*\.[a-z]{2,6})";
string input = @"Saturday, February 6, 2021 at 9:00 AM – 1:00 PM CST4 days from now · 9–21°C Partly CloudypinBraeswood Farmers Market5401 S Braeswood Blvd, 26096Show MapHide MapFarmers Market+1 913-620-5318info@bighome25.comGet DirectionsDetailsSouthwest Farmers Market located in the heart of City. Fresh farmed produce, pasture raised eggs, organically fed poultry, locally farmed honey, grass fed beef, fresh prepared gourmet foods, and delicious food trucks.Vendor Inquiries - info@bighome25.comFoodKid FriendlyFarmers market";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}