# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\+\d\s*\d(?:-?\d)+)([\w.-]+@[\w.-]+(?:\.[\w.-]+)*\.[a-z]{2,6})"
test_str = "Saturday, February 6, 2021 at 9:00 AM – 1:00 PM CST4 days from now · 9–21°C Partly CloudypinBraeswood Farmers Market5401 S Braeswood Blvd, 26096Show MapHide MapFarmers Market+1 913-620-5318info@bighome25.comGet DirectionsDetailsSouthwest Farmers Market located in the heart of City. Fresh farmed produce, pasture raised eggs, organically fed poultry, locally farmed honey, grass fed beef, fresh prepared gourmet foods, and delicious food trucks.Vendor Inquiries - info@bighome25.comFoodKid FriendlyFarmers market"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.