import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\+\\d\\s*\\d(?:-?\\d)+)([\\w.-]+@[\\w.-]+(?:\\.[\\w.-]+)*\\.[a-z]{2,6})";
final String string = "Saturday, February 6, 2021 at 9:00 AM – 1:00 PM CST4 days from now · 9–21°C Partly CloudypinBraeswood Farmers Market5401 S Braeswood Blvd, 26096Show MapHide MapFarmers Market+1 913-620-5318info@bighome25.comGet DirectionsDetailsSouthwest Farmers Market located in the heart of City. Fresh farmed produce, pasture raised eggs, organically fed poultry, locally farmed honey, grass fed beef, fresh prepared gourmet foods, and delicious food trucks.Vendor Inquiries - info@bighome25.comFoodKid FriendlyFarmers market";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}