import Foundation
let pattern = #"(\+\d\s*\d(?:-?\d)+)([\w.-]+@[\w.-]+(?:\.[\w.-]+)*\.[a-z]{2,6})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Saturday, February 6, 2021 at 9:00 AM – 1:00 PM CST4 days from now · 9–21°C Partly CloudypinBraeswood Farmers Market5401 S Braeswood Blvd, 26096Show MapHide MapFarmers Market+1 913-620-5318info@bighome25.comGet DirectionsDetailsSouthwest Farmers Market located in the heart of City. Fresh farmed produce, pasture raised eggs, organically fed poultry, locally farmed honey, grass fed beef, fresh prepared gourmet foods, and delicious food trucks.Vendor Inquiries - info@bighome25.comFoodKid FriendlyFarmers market"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)