import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\s\\w])(?:\\.{1,2}|\\.{4,})(?=[\\s\\w])";
final String string = "I was sent... to protect you.\n"
+ "I was sent.. to protect you.\n"
+ "I was sent.... to protect you.\n"
+ "I was sent ... to protect you.\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}