re = /(?<=[\s\w])(?:\.{1,2}|\.{4,})(?=[\s\w])/m
str = 'I was sent... to protect you.
I was sent.. to protect you.
I was sent.... to protect you.
I was sent ... to protect you.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result