$re = '/(?<=[\s\w])(?:\.{1,2}|\.{4,})(?=[\s\w])/m';
$str = 'I was sent... to protect you.
I was sent.. to protect you.
I was sent.... to protect you.
I was sent ... to protect you.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;