import re
regex = re.compile(r"(?<=[\s\w])(?:\.{1,2}|\.{4,})(?=[\s\w])", flags=re.MULTILINE)
test_str = ("I was sent... to protect you.\n"
"I was sent.. to protect you.\n"
"I was sent.... to protect you.\n"
"I was sent ... to protect you.\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)