const regex = /(?<=[\s\w])(?:\.{1,2}|\.{4,})(?=[\s\w])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\s\\w])(?:\\.{1,2}|\\.{4,})(?=[\\s\\w])', 'gm')
const str = `I was sent... to protect you.
I was sent.. to protect you.
I was sent.... to protect you.
I was sent ... to protect you.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);