import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^(?!(?:[^\\n\\d]*\\d){13})\\d*[.]?\\d{0,6}$";
        final String string = "1.22\n"
	 + "1.234567\n"
	 + "123456789012\n"
	 + "1234567.9012\n"
	 + "123456789012\n\n"
	 + "1234567890123\n"
	 + "1.2345678";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}