use strict;
my $str = '1.22
1.234567
123456789012
1234567.9012
123456789012
1234567890123
1.2345678';
my $regex = qr/^(?!(?:[^\n\d]*\d){13})\d*[.]?\d{0,6}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}