import re
regex = re.compile(r"^(?!(?:[^\n\d]*\d){13})\d*[.]?\d{0,6}$", flags=re.MULTILINE)
test_str = ("1.22\n"
"1.234567\n"
"123456789012\n"
"1234567.9012\n"
"123456789012\n\n"
"1234567890123\n"
"1.2345678")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")