const regex = /\b[Mm]od(?!e?r|if).*[\W_][hH]\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[Mm]od(?!e?r|if).*[\\W_][hH]\\b', 'gm')
const str = `new modified of module h 1
of mod H
new of mod_H
new moderate of mod_H
to modules (A & h)
new modified and moderate H
new modification of A mod_A
to modules (D & E)
to mode (F, G & A)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}