$re = '/\b[Mm]od(?!e?r|if).*[\W_][hH]\b/m';
$str = 'new modified of module h 1
of mod H
new of mod_H
new moderate of mod_H
to modules (A & h)
new modified and moderate H
new modification of A mod_A
to modules (D & E)
to mode (F, G & A)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);